FreeHost Support Board
FreeHost Support Board » Verschiedenes » Probleme mit Server & Co » Apache schmiert ständig ab » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Apache schmiert ständig ab
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
n!ck
Mitglied


Dabei seit: 09.01.2006
Beiträge: 37

traurig Apache schmiert ständig ab Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Mal wieder ohne eine Regelmäßigkeit verabschiedet sich Apache.
Ein Restart ist nicht per SSH und Plesk nicht möglich.

Fehlermeldung in Plesk:

Unable to make action: Unable to manage service by websrvmng: websrvmng: Service apache2 failed to start
0: /usr/local/psa/admin/htdocs/server/restart_services.php:28 psaerror(string "Unable to make action: Unable to manage service by websrvmng: websrvmng: Service apache2 failed to start")

Die restart_services.php ist von Plesk und verschlüsselt.

Mal wieder was neues ^^ Es könnte ja mal einfach was funktionieren unglücklich

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von n!ck: 27.05.2006 11:05.

24.05.2006 13:32 n!ck ist offline E-Mail an n!ck senden Beiträge von n!ck suchen Nehmen Sie n!ck in Ihre Freundesliste auf
Kleinbreuer
Super Moderator


Dabei seit: 08.03.2006
Beiträge: 508

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hey,

versuch mal bitte folgende Sachen:

/etc/init.d/apache2 restart
apache2ctl restart
apache2ctl stop
apache2ctl start
/etc/init.d/apache2 start
killall apache2

Kannst du nicht irgendwie das mit Plesk ausstellen, also dass Plesk den Apache neu startet? Eventuell könntest du den Cronjob von Plesk deaktivieren.....

__________________
Support Freehost Script
24.05.2006 15:14 Kleinbreuer ist offline E-Mail an Kleinbreuer senden Beiträge von Kleinbreuer suchen Nehmen Sie Kleinbreuer in Ihre Freundesliste auf
n!ck
Mitglied


Dabei seit: 09.01.2006
Beiträge: 37

Themenstarter Thema begonnen von n!ck
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Werd das das nächste mal so probieren.

Und nach dem Cron habe ich bereits geschaut jedoch nichts gefunden. Werde das aber morgen nochmal machen.

Ansonsten wolltest du ja morgen danach schauen Zunge raus

Wie ich dir bereits geschrieben hab bin ich ja leider nicht der einzigste der mit dem Script in Verbindung mit Plesk Probleme hat.

Sobald ich eine Lösung gefunden habe werde ich sie natürlich kund geben. Ansonsten musst du wirklich mal danach schauen. Hab doch so wenig Ahnung Augen rollen
24.05.2006 23:03 n!ck ist offline E-Mail an n!ck senden Beiträge von n!ck suchen Nehmen Sie n!ck in Ihre Freundesliste auf
Kleinbreuer
Super Moderator


Dabei seit: 08.03.2006
Beiträge: 508

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hey,

habe eben nochmal über ne Stunde danach gesehen, und ich finde einfach keinen Fehler bzw. der Apache scheint ohne Fehlermeldung einfach abzustürzen....sehr komisch, ich glaube ich werde mal ein wenig Web Recherche betreiben...

Gruss

__________________
Support Freehost Script
25.05.2006 14:02 Kleinbreuer ist offline E-Mail an Kleinbreuer senden Beiträge von Kleinbreuer suchen Nehmen Sie Kleinbreuer in Ihre Freundesliste auf
n!ck
Mitglied


Dabei seit: 09.01.2006
Beiträge: 37

Themenstarter Thema begonnen von n!ck
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Bin weiter gekommen.

Habe jetzt einfach den Cron bei Plesk deaktiviert und seit knapp 24 Stunden kein Absturz mehr.

Was nun jedoch das Problem ist, seit her bekommen neue User keine PHP-Unterstützung mehr. Aktiviert im ACP ist es für die betroffenenen Accounts.

phpinfo geht bei den alten accounts. Bei neuen jedoch nicht. Hat das was mit dem deaktivieren des Crons zu tun? Wird der Apache restart benötigt?

Edit: Hab mal nen Apache Restart von Hand gemacht. -> Kein Effekt.

Was ich gerade noch entdeckt habe.

Es fehlen ein paar Einträge in der freehost.conf 0.o

---------------------------------------------------------------------------
---
25.Mai 2006 23:30 Uhr
Edit²:
Ok... der Plesk Cronjob ist notwendig damit die Einträge in der freehost.conf gemacht werden. Ebenfalls wird dann PHP aktviert.

Nun kommen wir also wieder zurück.

Mit dem aktivierten Plesk Cron /root/restart.sh schmiert alle paar Stunden Apache ab. -> Verzweiflung.

---------------------------------------------------------------------------
---
26. Mai 2006 09:30 Uhr
Edit³:
Wie erwartet war der Server heute morgen offline. Dein Tip im 2. Beitrag hat leider alles keinen Erfolg gehabt.

Dieser Beitrag wurde 6 mal editiert, zum letzten Mal von n!ck: 26.05.2006 09:28.

25.05.2006 23:25 n!ck ist offline E-Mail an n!ck senden Beiträge von n!ck suchen Nehmen Sie n!ck in Ihre Freundesliste auf
Kleinbreuer
Super Moderator


Dabei seit: 08.03.2006
Beiträge: 508

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hey,

was meinst du damit dass in der freehost.conf ein paar Einträge fehlen?! Das würde natürlich einiges erklären, also wenn beim Schreiben oder so ein Fehler auftreten würde, und die Datei korrupt würde wäre das für das Script doch schon eher ein Problem

Christopher

__________________
Support Freehost Script
27.05.2006 11:11 Kleinbreuer ist offline E-Mail an Kleinbreuer senden Beiträge von Kleinbreuer suchen Nehmen Sie Kleinbreuer in Ihre Freundesliste auf
rainer


Dabei seit: 10.05.2006
Beiträge: 18
Herkunft: San Francisco, CA

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

ich habe den cron der die restart.sh im plesk aufruft gestern morgen deaktiviert und seitdem läuft er.
wer schreibt denn in die freehost conf bzw. wer greifft darauf zu? wenn das script da rein schreibt und in dem moment die restart.sh aufgerufen wird und versucht freehost.conf zu lesen, wird das nicht gehen denke ich mal. das würde erklären warum die abstürze unregelmässig sind. das ist natürlich nur ne theorie da ich von linux nicht unbedingt so die ahnung habe -smile
wie gesagt , seitdem der plesk cron raus ist, läuft der server anstandslos.

dann noch was anderes, meine blokierliste für "verbotene" domain namen und e-mailadressen geht nicht. das script ignoriert die einträge.
das war auch schon so als der plesk cron noch lief.

rainer
27.05.2006 18:28 rainer ist offline E-Mail an rainer senden Beiträge von rainer suchen Nehmen Sie rainer in Ihre Freundesliste auf
bjoern
Administrator


Dabei seit: 29.03.2005
Beiträge: 533

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

update.php macht das, die schreibt die freehost.conf.

Solltest natürlich gucken was du wann startest das ist natürlich klar.

__________________
Support Freehost Script
27.05.2006 19:39 bjoern ist offline E-Mail an bjoern senden Beiträge von bjoern suchen Nehmen Sie bjoern in Ihre Freundesliste auf
n!ck
Mitglied


Dabei seit: 09.01.2006
Beiträge: 37

Themenstarter Thema begonnen von n!ck
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hab hier noch was gefunden.

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
*** glibc detected *** corrupted double-linked list: 0x08438550 ***
[Fri May 26 12:54:02 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri May 26 12:54:02 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 12:54:02 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 12:54:02 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Fri May 26 12:54:02 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 12:54:02 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 12:54:03 2006] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations
[Fri May 26 12:57:02 2006] [notice] caught SIGTERM, shutting down
*** glibc detected *** corrupted double-linked list: 0x08438520 ***
[Fri May 26 12:57:02 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri May 26 12:57:02 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 12:57:02 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 12:57:02 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Fri May 26 12:57:03 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 12:57:03 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 12:57:03 2006] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations
[Fri May 26 12:57:32 2006] [error] [client 84.164.13.205] File does not exist: /var/www/vhosts/easyclan.de/httpdocs/user_web/kracken/favicon.ico
[Fri May 26 12:57:32 2006] [error] [client 84.164.13.205] script '/var/www/vhosts/easyclan.de/httpdocs/user_web/kracken/file.php' not found or unable to stat
[Fri May 26 13:00:01 2006] [notice] caught SIGTERM, shutting down


Darauf folgt dann ständig:
code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
*** glibc detected *** corrupted double-linked list: 0x084385d0 ***
[Fri May 26 13:09:02 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri May 26 13:09:02 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 13:09:02 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 13:09:02 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Fri May 26 13:09:03 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 13:09:03 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 13:09:03 2006] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations
[Fri May 26 13:12:01 2006] [notice] caught SIGTERM, shutting down
*** glibc detected *** corrupted double-linked list: 0x084385c0 ***
[Fri May 26 13:12:02 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri May 26 13:12:02 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 13:12:02 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 13:12:02 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Fri May 26 13:12:02 2006] [warn] RSA server certificate CommonName (CN) `h737222.serverkompetenz.net' does NOT match server name!?
[Fri May 26 13:12:02 2006] [warn] RSA server certificate CommonName (CN) `plesk' does NOT match server name!?
[Fri May 26 13:12:02 2006] [notice] Apache/2.0.53 (Linux/SUSE) configured -- resuming normal operations


Hilft das weiter?

Ist aus der /var/log/apache2/error.log

Wenn der restart.sh Cron aktiviert ist, werden keine Einträge in der freehost.conf gemacht wenn neue User Registriert werden.

Das abnormale jedoch ist, das die Subdomain und Ordner trotzdem erreichbar sind. Nur PHP läuft dann nicht. Sehr sehr komisch.

Ich habe aber so das Gefühl das wir dem Problem schon ziemlich nahe sind *thumbs up!*
28.05.2006 00:37 n!ck ist offline E-Mail an n!ck senden Beiträge von n!ck suchen Nehmen Sie n!ck in Ihre Freundesliste auf
cws
Mitglied


Dabei seit: 30.03.2005
Beiträge: 34
Herkunft: Germany

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Wurde schon länger nix mehr geschrieben, aber wenn einer auch so ein Problem hat:

es könnte an einem Apache Modul welches fehlerhaft ist liegen.

dieses *** glibc detected *** corrupted double-linked list: 0x084385c0 ***

könnte auf das modul (auth-mysql) hinweisen - dieses mal rausnehmen und testen obs dann rund läuft.

__________________
CWS
18.07.2006 16:21 cws ist offline E-Mail an cws senden Homepage von cws Beiträge von cws suchen Nehmen Sie cws in Ihre Freundesliste auf
Kleinbreuer
Super Moderator


Dabei seit: 08.03.2006
Beiträge: 508

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Jep, das sind normalerweise fehlerhafte Module, ist nur nicht einfach rauszukriegen welches rotes Gesicht

__________________
Support Freehost Script
18.07.2006 18:28 Kleinbreuer ist offline E-Mail an Kleinbreuer senden Beiträge von Kleinbreuer suchen Nehmen Sie Kleinbreuer in Ihre Freundesliste auf
k.soellch


Dabei seit: 01.01.1970
Beiträge:

Apache 2 Startet nach Plesk Update nicht mehr Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Folgendes Problem nachdem ich Plesk auf die aktuelle Version geupdated habe

Unable to make action: Unable to manage service by websrvmng: websrvmng: Service /etc/init.d/apache2 failed to start

0: /usr/local/psa/admin/plib/common_func.php3:156
psaerror(string 'Unable to make action: Unable to manage service by websrvmng: websrvmng: Service /etc/init.d/apache2 failed to start')
1: /usr/local/psa/admin/htdocs/server/restart_services.php:28

kann mir da bitte einer helfen?!

Danke

k.soellch
21.11.2007 17:16 k.soellch ist offline Beiträge von k.soellch suchen Nehmen Sie k.soellch in Ihre Freundesliste auf
bjoern
Administrator


Dabei seit: 29.03.2005
Beiträge: 533

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hallo,

Scheint ein Problem mit dem Plesk zu sein und nicht mit dem Script. Ich würde dir vorschlagen an die Entwickler von Plesk zu richten. Dort bekommst du schneller Hilfe als hier bestimmt. Augenzwinkern

Gruß

Björn

__________________
Support Freehost Script
22.11.2007 14:16 bjoern ist offline E-Mail an bjoern senden Beiträge von bjoern suchen Nehmen Sie bjoern in Ihre Freundesliste auf
Baumstruktur | Brettstruktur
Gehe zu:
Neues Thema erstellen Antwort erstellen
FreeHost Support Board » Verschiedenes » Probleme mit Server & Co » Apache schmiert ständig ab

Forensoftware: Burning Board 2.3.6, entwickelt von WoltLab GmbH